Visual App Viewer – npm install

Home Forums Convertigo developers Forums as moved to Stack Overflow. Visual App Viewer – npm install

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #255883

    Alexandre Perret
    Participant

    Hi

    I changed my PC for a laptop under windows 10 but I can’t make it build my app.

    I tried different Node.js versions, my proxy is properly configured.
    Any help would be greatly appreciated !

    Thank you

    Attachments:
    You must be logged in to view attached files.
    #255884

    Gregory Vorbe
    Moderator

    Hello Alexandre,

    It should work correctly with NodeJS 8.11.x.
    If you previously installed node version 10.x or 12.x, make sure they are correctly uninstalled.
    Verify versions with commands:

    node -v
    npm -v

    Try uninstalling nodeJS and reinstall it (latest V8.X)

    In the Studio, right-click your project and select ‘Reload your project’, this will reload the Mobile Builder Template you choose (Application > Template project > mobilebuilder_tpl_7_X_Y).
    Then, right-click ‘Application’ object in project’ss tree view and select ‘Re-install packages and Execute’, this should rebuild completly your Mobile Builder Application.

    QA&Support

    #255885

    Alexandre Perret
    Participant

    Hello

    (this topic is the continuation of this one : https://www.convertigo.com/Forums/topic/visual-app-viewer-npm-install/ because the page hang on my browser with processor at 100% 🙁 )

    I finally got it working. The problem is because of the node-sass library that needs github access. This can’t be accessed through our proxies so I needed to install it manually on my computer to make it available via an environment variable …

    #255890

    Gregory Vorbe
    Moderator

    Hello Alexandre,

    I am glad you found out the solution, I was far from suspecting a proxy access concern, though we already experienced it with the downloading of the whole bunch of node_modules, not only the Node-sass library (different error messages).

    I merged your answer with the original topic and put your log as an attachment as it seemed to cause the script lock.

    Thank you.
    QA&Support

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.