Visual App Viewer error

Home Forums Convertigo Products Visual App Viewer error

This topic contains 4 replies, has 2 voices, and was last updated by  edguih@gmail.com 11 months, 4 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #235904

    edguih@gmail.com
    Participant

    Hi,

    I’m newer here and I’m trying to execute sample applications but I get a npm error.
    Attached the log.

    Here some extrat of the log:
    ————

    16 verbose Windows_NT 10.0.10240
    17 verbose argv “C:\\Program Files (x86)\\nodejs\\node.exe” “C:\\Program Files (x86)\\nodejs\\node_modules\\npm\\bin\\npm-cli.js” “run” “ionic:serve:eval” “–nobrowser” “–port” “8100” “–livereload-port” “35729” “–dev-logger-port” “53703”
    18 verbose node v9.9.0
    19 verbose npm v5.6.0
    20 error code ELIFECYCLE
    21 error errno 1
    22 error Convertigo-template-app@ ionic:serve:eval: ionic-app-scripts serve --enableLint false --sourceMapType eval "8100" "35729" "53703"
    22 error Exit status 1
    23 error Failed at the Convertigo-template-app@ ionic:serve:eval script.
    23 error This is probably not a problem with npm. There is likely additional logging output above.
    24 verbose exit [ 1, true ]
    ————–

    PS: Sorry for my bad english.

    Thanks in advance for the help!

    #235905

    Gregory Vorbe
    Moderator

    Hi there,

    Could you rename the file to .txt, attachment was refused for security reasons.
    What version of Convertigo Studio are you using?
    What is the sample project name?
    Have a look at the following threads if it can solve your problem: https://www.convertigo.com/Forums/topic/error-on-windows-10-when-launch-application-viewer/
    If it was a fresh NodeJS install, it sometimes requires that you restart the Studio or even that relog your Windows session.
    You can also try to reload the project by right-clicking on it and selecting “Reload your project”, then right-click on “Application” and select “Re-install packages and Execute”.

    QA&Support

    #235907

    edguih@gmail.com
    Participant

    I’m using convertigo 7.5.1;
    I had tried HelloWorld and RetailStore samples.
    The solution of that link didn’t solve the problem. By the way, yes I’m using windows 10.
    Tried to “reload project” and “re-install packages and Exexcute”, reboot all S.O. but didn’t work too.

    Attachments:
    You must be logged in to view attached files.
    #235909

    Gregory Vorbe
    Moderator

    In the log file, I see that the Node.js version is 9.9.0.
    Convertigo 7.5.1 has only been qualified with the Node.js version 8.11.0 LTS.
    The issue may come from here.
    If possible, try to uninstall Node.js 9.9.0 and install version 8.11.0 LTS.
    Then, reload your project and re-install packages.
    Thank you.

    QA&Support

    #235910

    edguih@gmail.com
    Participant

    Thank You very Much!!!
    This worked!

    Have a Nice Day!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.