problem when changing the node platform

Home Forums Convertigo Products problem when changing the node platform

This topic contains 6 replies, has 4 voices, and was last updated by  admin 6 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #243535

    hello,
    I changed the node platform and now, when I open the visual app viewer, I get this error :

    \o/
    npm ERR! C:\Users\utilisateur\AppData\Roaming\npm-cache\_logs\2018-06-27T15_12_08_754Z-debug.log
    npm ERR! A complete log of this run can be found in:

    In the file 2018-06-27T15_12_08_754Z-debug.log, I have :

    13 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5)
    14 verbose pkgid Convertigo-template-app@
    15 verbose cwd C:\Users\utilisateur\Convertigo Mobility Platform\Convertigo Mobility Platform Studio 7.5.1\workspace\Maprospection\_private\ionic
    16 verbose Windows_NT 10.0.17134
    17 verbose argv “C:\\Program Files\\nodejs\\node.exe” “C:\\Users\\utilisateur\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js” “run” “ionic:serve:eval” “–nobrowser” “–port” “8100” “–livereload-port” “35729” “–dev-logger-port” “53703”
    18 verbose node v8.11.1
    19 verbose npm v5.8.0
    20 error code ELIFECYCLE
    21 error errno 1
    22 error Convertigo-template-app@ ionic:serve:eval: ionic-app-scripts serve --enableLint false --sourceMapType eval "8100" "35729" "53703"
    22 error Exit status 1
    23 error Failed at the Convertigo-template-app@ ionic:serve:eval script.
    23 error This is probably not a problem with npm. There is likely additional logging output above.
    24 verbose exit [ 1, true ]

    how can I fix it? thanks

    #243536

    admin
    Keymaster

    Hello if I understand correctly you installed a news NodeJS version ?
    Did you install the v8.11.1 ?

    Thx
    Convertigo Support Team.

    • This reply was modified 6 months, 3 weeks ago by  admin.
    #243538

    Gregory Vorbe
    Moderator

    Hi,

    What version of Node JS do you now have?
    Only Node JS up to v8.11.3 LTS is currently supported and not the 10.5.0 Current that you can also find on the Node JS web site.
    If version is correct, you may restart the Convertigo Studio or relog your Windows session.
    Verify Node Js is still on your Windows path too.

    QA&Support

    #243540

    I have the version 8.11.1. Does this version can be used with Convertigo?

    The log file is attached.

    #243541

    Gregory Vorbe
    Moderator

    Try to restart Studio and if it still does not work relog your user session.

    QA&Support

    #243566

    If you needed to downgrade to Node JS v8.11.3 (or 8.11.X), instead of double click MobileApplication/Application on Projects, right click and choose the option “Re-install packages and Execute” to clean previously downloaded dependencies and stuff, otherwise the error continues even after restarting (verbose argv “C:\\Program Files\\nodejs\\node.exe” “C:\\Users\\utilisateur\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js” “run” “ionic:serve:eval” “–nobrowser” “–port” “8100” “–livereload-port” “35729” “–dev-logger-port” “53703”).

    Also, as a suggestion to the Convertigo team, the version requirement should be explicit on the Convertigo Application screen (when you don’t have Node, and it displays the node requirement), and maybe in a post-install README or something.

    Rgds.

    #243573

    admin
    Keymaster

    Hello Pedro,

    Thank you for your post. Yes. node version requirement should be more explicit. We will fix this in the next release.

    Best rds
    Convertigo Team

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.